diff options
Diffstat (limited to 'flake.nix')
-rw-r--r-- | flake.nix | 20 |
1 files changed, 14 insertions, 6 deletions
@@ -33,10 +33,12 @@ rec { email = "tjkeller.xyz"; fullname = "Tim Keller"; }; + homeStateVersion = "24.05"; # Lowest of systems is fine mkNixosConfiguration = hostname: nixpkgs.lib.nixosSystem { inherit system; specialArgs = { inherit inputs; + inherit hostname; inherit userDetails; }; modules = [ @@ -50,6 +52,7 @@ rec { users.${userDetails.username} = import ./modules/home; extraSpecialArgs = { inherit userDetails; + inherit homeStateVersion; }; sharedModules = [ inputs.arkenfox.hmModules.arkenfox @@ -60,11 +63,16 @@ rec { ]; }; in { - nixosConfigurations = { - T430 = mkNixosConfiguration "T430"; - T495 = mkNixosConfiguration "T495"; - hp-envy-office = mkNixosConfiguration "hp-envy-office"; - optiplex = mkNixosConfiguration "optiplex"; - }; + nixosConfigurations = builtins.listToAttrs (map (hostname: { + name = hostname; + value = mkNixosConfiguration hostname; + }) [ + # Configured system hostnames go here + "T430" + "T495" + "hp-envy-office" + "libreX60" + "optiplex" + ]); }; } |