summaryrefslogtreecommitdiff
path: root/modules/home/firefox.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/home/firefox.nix')
-rw-r--r--modules/home/firefox.nix11
1 files changed, 2 insertions, 9 deletions
diff --git a/modules/home/firefox.nix b/modules/home/firefox.nix
index 3ae1278..0977bbe 100644
--- a/modules/home/firefox.nix
+++ b/modules/home/firefox.nix
@@ -1,4 +1,4 @@
-{
+{ userDetails, ... }: {
programs.firefox = {
# TODO see if there is way to login to moz account in profile
enable = true;
@@ -28,7 +28,7 @@
"toolkit.legacyUserProfileCustomizations.stylesheets" = true;
"browser.compactmode.show" = true;
"browser.uidensity" = 1; # Compact
- "browser.download.dir" = /home/timmy/dls; # FF will create this dir if it doesn't exist
+ "browser.download.dir" = userDetails.home.downloads; # FF will create this dir if it doesn't exist
"browser.aboutConfig.showWarning" = false; # arkenfox does
"app.normandy.first_run" = false;
"browser.uiCustomization.state" = builtins.readFile ./resources/firefox/uiCustomization.json; # Toolbar etc.
@@ -51,13 +51,6 @@
id = 1;
inherit search;
};
- Test = {
- id = 2;
- inherit search;
- inherit arkenfox;
- inherit userChrome;
- inherit settings;
- };
};
};
}