summaryrefslogtreecommitdiff
path: root/modules/home/htop.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/home/htop.nix')
-rw-r--r--modules/home/htop.nix38
1 files changed, 38 insertions, 0 deletions
diff --git a/modules/home/htop.nix b/modules/home/htop.nix
new file mode 100644
index 0000000..523fee8
--- /dev/null
+++ b/modules/home/htop.nix
@@ -0,0 +1,38 @@
+{ config, ... }: {
+ programs.htop.enable = true;
+ programs.htop.settings = {
+ fields = with config.lib.htop.fields; [
+ PID
+ USER
+ 124 # EXE
+ PERCENT_CPU
+ PERCENT_MEM
+ STARTTIME
+ ELAPSED # time elapsed since process start
+ IO_READ_RATE
+ RBYTES # num read bytes
+ IO_WRITE_RATE
+ WBYTES # num written bytes
+ TIME
+ STIME # sys time
+ CSTIME # child sys time
+ NICE
+ STATE
+ PRIORITY
+ 125 # CWD
+ ];
+ } // (with config.lib.htop; leftMeters [
+ (bar "AllCPUs2")
+ (bar "CPU")
+ (bar "Memory")
+ (bar "DiskIO")
+ (bar "NetworkIO")
+ ]) // (with config.lib.htop; rightMeters [
+ (text "Hostname")
+ (text "Clock")
+ (text "Uptime")
+ (text "Battery")
+ (text "LoadAverage")
+ (text "Tasks")
+ ]);
+}