summaryrefslogtreecommitdiff
path: root/modules/home/initial-home-setup.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/home/initial-home-setup.nix')
-rw-r--r--modules/home/initial-home-setup.nix5
1 files changed, 4 insertions, 1 deletions
diff --git a/modules/home/initial-home-setup.nix b/modules/home/initial-home-setup.nix
index a7119b9..2348b79 100644
--- a/modules/home/initial-home-setup.nix
+++ b/modules/home/initial-home-setup.nix
@@ -1,4 +1,4 @@
-{ config, lib, ... }: {
+{ config, lib, pkgs, userDetails, ... }: {
home.activation = {
cloneRepos = lib.hm.dag.entryAfter ["writeBoundary"] ''
export PATH="${config.home.path}/bin:$PATH"
@@ -14,5 +14,8 @@
export PATH="$HOME/.local/bin/misc:$PATH"
run mimewiz # already verbose
'';
+ createDirs = lib.hm.dag.entryAfter ["writeBoundary"] ''
+ run mkdir -p $VERBOSE_ARG "${userDetails.home.downloads}"
+ '';
};
}