summaryrefslogtreecommitdiff
path: root/modules/home/theme.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/home/theme.nix')
-rw-r--r--modules/home/theme.nix19
1 files changed, 15 insertions, 4 deletions
diff --git a/modules/home/theme.nix b/modules/home/theme.nix
index 4128e1d..3bc1d8e 100644
--- a/modules/home/theme.nix
+++ b/modules/home/theme.nix
@@ -29,6 +29,18 @@ in {
description = "mint-y icons color eg. 'Aqua' or 'Red'";
};
};
+ theme.font = {
+ sansSerif = lib.mkOption {
+ type = lib.types.str;
+ default = "Inter";
+ description = "default sans serif font";
+ };
+ sansSerif = lib.mkOption {
+ type = lib.types.str;
+ default = "CommitMono";
+ description = "default monospace font";
+ };
+ };
};
config = {
@@ -43,8 +55,7 @@ in {
name = transformColorValue config.theme.mint.icons.color;
};
font = {
- package = pkgs.inter;
- name = "Inter";
+ name = config.theme.font.sansSerif;
};
cursorTheme = {
name = "Adwaita";
@@ -64,8 +75,8 @@ in {
platformTheme.name = "gtk3";
};
fonts.fontconfig.defaultFonts = {
- sansSerif = [ "Inter" ];
- monospace = [ "CommitMono" ];
+ sansSerif = [ config.theme.fonts.sansSerif ];
+ monospace = [ config.theme.fonts.monospace ];
};
};
}