summaryrefslogtreecommitdiff
path: root/modules/hosts/optiplex/configuration.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/hosts/optiplex/configuration.nix')
-rw-r--r--modules/hosts/optiplex/configuration.nix50
1 files changed, 50 insertions, 0 deletions
diff --git a/modules/hosts/optiplex/configuration.nix b/modules/hosts/optiplex/configuration.nix
new file mode 100644
index 0000000..cbde612
--- /dev/null
+++ b/modules/hosts/optiplex/configuration.nix
@@ -0,0 +1,50 @@
+{ config, lib, pkgs, ... }: {
+ imports = [
+ ./hardware-configuration.nix
+ ];
+ networking.hostName = "optiplex";
+
+ bootloader.mode = "efi";
+
+ # Allow unfree for nvidia + others
+ nixpkgs.config.allowUnfree = true;
+
+ # Enable extra software pkgs
+ software.desktop = {
+ chromium.enable = true;
+ cad.enable = true;
+ crypto.enable = true;
+ graphics.enable = true;
+ office.enable = true;
+ utilities.enable = true;
+ };
+
+ # Install more programs
+ environment.systemPackages = with pkgs; [
+ prismlauncher
+ spotify
+ #vintagestory
+ ];
+
+ # Enable network drives
+ nas.enable = true;
+
+ # Disable wifi
+ wifi.enable = false;
+
+ networking.hosts = {
+ "192.168.77.3" = [ "devel" ];
+ };
+
+ # Use nvidia driver
+ services.xserver.videoDrivers = [ "nvidia" ];
+ hardware.nvidia = {
+ modesetting.enable = true; # Required
+ powerManagement.enable = false; # Can cause bugs
+ nvidiaSettings = true;
+ open = false; # Not compatible w/ GTX-1050
+ package = config.boot.kernelPackages.nvidiaPackages.stable; # Still good for 1050
+ };
+
+ system.stateVersion = "24.11";
+}