summaryrefslogtreecommitdiff
path: root/modules/root/software/utils.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/root/software/utils.nix')
-rw-r--r--modules/root/software/utils.nix30
1 files changed, 0 insertions, 30 deletions
diff --git a/modules/root/software/utils.nix b/modules/root/software/utils.nix
deleted file mode 100644
index 1efdb18..0000000
--- a/modules/root/software/utils.nix
+++ /dev/null
@@ -1,30 +0,0 @@
-{ pkgs, lib, config, ... }: {
- options = {
- software.utils.enable = lib.mkEnableOption "enables dev apps";
- };
-
- config = lib.mkIf config.software.utils.enable {
- programs.zsh.enable = true;
- users.defaultUserShell = pkgs.zsh;
- services.openssh.enable = true;
-
- environment.systemPackages = with pkgs; [
- ddcutil # TODO
- fastfetch
- htop
- light
- neovim
- p7zip
- powertop
- pv
- rsync
- screen
- scrot
- smartmontools
- stress
- testdisk
- tmux
- xxHash
- ];
- };
-}