summaryrefslogtreecommitdiff
path: root/modules/root/wifi.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/root/wifi.nix')
-rw-r--r--modules/root/wifi.nix10
1 files changed, 10 insertions, 0 deletions
diff --git a/modules/root/wifi.nix b/modules/root/wifi.nix
new file mode 100644
index 0000000..54f9089
--- /dev/null
+++ b/modules/root/wifi.nix
@@ -0,0 +1,10 @@
+{ pkgs, lib, config, ... }: {
+ options = {
+ wifi.enable = lib.mkEnableOption "enables wifi";
+ };
+
+ config = lib.mkIf config.wifi.enable {
+ # networking.wireless.enable = true; # Enables wireless support via wpa_supplicant.
+ networking.networkmanager.enable = true; # Easiest to use and most distros use this by default.
+ };
+}