summaryrefslogtreecommitdiff
path: root/modules/root/x11/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/root/x11/default.nix')
-rw-r--r--modules/root/x11/default.nix30
1 files changed, 30 insertions, 0 deletions
diff --git a/modules/root/x11/default.nix b/modules/root/x11/default.nix
new file mode 100644
index 0000000..8fa1d27
--- /dev/null
+++ b/modules/root/x11/default.nix
@@ -0,0 +1,30 @@
+{ pkgs, lib, config, ... }: {
+ options = {
+ xserver.enable = lib.mkEnableOption "enables xserver";
+ };
+
+ config = lib.mkIf config.xserver.enable {
+ services.xserver.enable = true;
+ services.xserver.displayManager.startx.enable = true;
+ services.libinput.enable = true; # Enable touchpad support
+
+ environment.systemPackages = with pkgs; [
+ unclutter
+ xcape
+ xclip
+ xdotool
+ xorg.setxkbmap
+ xorg.xinput
+ xorg.xkill
+ xorg.xrandr
+ xorg.xset
+ xwallpaper
+ # Patch startx to be compliant with xdg base dir spec
+ (xorg.xinit.overrideAttrs (old: rec {
+ patches = [
+ ./xinit-startx-xdg.patch
+ ];
+ }))
+ ];
+ };
+}