{ config, lib, pkgs, userDetails, ... }: {
	home.activation = {
		cloneRepos = lib.hm.dag.entryAfter ["writeBoundary"] ''
			export PATH="${config.home.path}/bin:$PATH"
			${builtins.readFile ./resources/activation-scripts/clone-repos.sh}
		'';
		linkZshProfile = lib.hm.dag.entryAfter ["writeBoundary"] ''
			run ln -sf $VERBOSE_ARG $HOME/.config/zsh/zprofile $HOME/.zprofile
		'';
		cleanupHome = lib.hm.dag.entryAfter ["writeBoundary"] ''
			run rm -f $VERBOSE_ARG $HOME/{.zcompdump,.zshrc,.zsh_history,.bash_history}
		'';
		mimewiz = lib.hm.dag.entryAfter ["writeBoundary"] ''
			export PATH="${pkgs.xdg-utils}/bin:$PATH"
			export PATH="$HOME/.local/bin/misc:$PATH"
			run mimewiz -i # already verbose
		'';
		createDirs = with userDetails.home; lib.hm.dag.entryAfter ["writeBoundary"] ''
			run mkdir -p $VERBOSE_ARG "${downloads}" "${documents}" "${pictures}"
		'';
	};
}