diff options
author | Tim Keller <tjkeller.xyz> | 2024-10-20 13:19:39 -0500 |
---|---|---|
committer | Tim Keller <tjkeller.xyz> | 2024-10-20 13:19:39 -0500 |
commit | cd4520a475d0b43a3d600636494eb3b4916f07cd (patch) | |
tree | 4df2b3e049323bf8afc3c499a429b8db540d86f0 /flake.nix | |
parent | 8d917a59ee6f7d4ccb2d901ae72c52d143357699 (diff) | |
download | nixos-cd4520a475d0b43a3d600636494eb3b4916f07cd.tar.xz nixos-cd4520a475d0b43a3d600636494eb3b4916f07cd.zip |
use nixos module for home manager
Diffstat (limited to 'flake.nix')
-rw-r--r-- | flake.nix | 35 |
1 files changed, 24 insertions, 11 deletions
@@ -21,7 +21,7 @@ pkgs = nixpkgs.legacyPackages.${system}; userDetails = { username = "timmy"; - home.root = /home/timmy; + home.root = "/home/timmy"; home.downloads = /home/timmy/dls; email = "tjkeller.xyz"; fullname = "Tim Keller"; @@ -35,6 +35,19 @@ modules = [ ./modules/hosts/${hostname}/configuration.nix ./modules/root + home-manager.nixosModules.home-manager { + home-manager = { + useGlobalPkgs = true; + useUserPackages = true; + users.${userDetails.username} = import ./modules/home; + extraSpecialArgs = { + inherit userDetails; + }; + sharedModules = [ + inputs.arkenfox.hmModules.arkenfox + ]; + }; + } ]; }; in { @@ -43,15 +56,15 @@ T495 = mkNixosConfiguration "T495"; }; - homeConfigurations.${userDetails.username} = home-manager.lib.homeManagerConfiguration { - inherit pkgs; - extraSpecialArgs = { - inherit userDetails; - }; - modules = [ - ./modules/home - inputs.arkenfox.hmModules.arkenfox - ]; - }; + #homeConfigurations.${userDetails.username} = home-manager.lib.homeManagerConfiguration { + # inherit pkgs; + # extraSpecialArgs = { + # inherit userDetails; + # }; + # modules = [ + # ./modules/home + # inputs.arkenfox.hmModules.arkenfox + # ]; + #}; }; } |