summaryrefslogtreecommitdiff
path: root/modules/grub.nix
diff options
context:
space:
mode:
authorTim Keller <tjk@tjkeller.xyz>2024-10-02 22:07:10 -0500
committerTim Keller <tjk@tjkeller.xyz>2024-10-02 22:07:10 -0500
commit4730b215fdc4095800fedfdf690c12fec994bb6b (patch)
tree3c746ece0089625a8093d4ae6bf1149ea903b7dc /modules/grub.nix
parent34b0bb8df42194a0ea433592e3cac27546f0af4e (diff)
downloadnixos-4730b215fdc4095800fedfdf690c12fec994bb6b.tar.xz
nixos-4730b215fdc4095800fedfdf690c12fec994bb6b.zip
more reorganizing and modularizing
Diffstat (limited to 'modules/grub.nix')
-rw-r--r--modules/grub.nix26
1 files changed, 0 insertions, 26 deletions
diff --git a/modules/grub.nix b/modules/grub.nix
deleted file mode 100644
index 47227d1..0000000
--- a/modules/grub.nix
+++ /dev/null
@@ -1,26 +0,0 @@
-{ lib, config, ... }: {
- options = {
- grub.enable = lib.mkEnableOption "enables docker";
- grub.mode = lib.mkOption {
- type = lib.types.enum [ "efi" "bios" ];
- default = "efi";
- description = "grub mode efi or bios";
- };
- grub.biosDevice = lib.mkOption {
- type = lib.types.str;
- description = "device to install grub on";
- };
- };
-
- config = lib.mkIf config.grub.enable {
- boot.loader = {
- grub = {
- enable = true;
- efiSupport = config.grub.mode == "efi";
- efiInstallAsRemovable = config.grub.mode == "efi";
- device = if config.grub.mode == "bios" then config.grub.biosDevice else "nodev";
- };
- efi.efiSysMountPoint = "/boot/efi";
- };
- };
-}