summaryrefslogtreecommitdiff
path: root/modules/home/firefox.nix
diff options
context:
space:
mode:
authorTim Keller <tjkeller.xyz>2024-11-07 23:15:46 -0600
committerTim Keller <tjkeller.xyz>2024-11-07 23:15:46 -0600
commita6033a1b4cfdc5f37f4185752c2830bd5a45792a (patch)
treec8f9ac91390fdfae5d7cd6fb4334043e62eebd8b /modules/home/firefox.nix
parente28e7847ffbbcd49489a90f9b8f2eb07fb65a4a7 (diff)
downloadnixos-a6033a1b4cfdc5f37f4185752c2830bd5a45792a.tar.xz
nixos-a6033a1b4cfdc5f37f4185752c2830bd5a45792a.zip
firefox stuff and add some software and small fixes
Diffstat (limited to 'modules/home/firefox.nix')
-rw-r--r--modules/home/firefox.nix20
1 files changed, 19 insertions, 1 deletions
diff --git a/modules/home/firefox.nix b/modules/home/firefox.nix
index a55708a..5e015ff 100644
--- a/modules/home/firefox.nix
+++ b/modules/home/firefox.nix
@@ -1,4 +1,4 @@
-{ userDetails, ... }: {
+{ pkgs, userDetails, ... }: {
programs.firefox = {
# TODO see if there is way to login to moz account in profile
enable = true;
@@ -12,6 +12,18 @@
urls = [{ template = "https://search.tjkeller.xyz/search?q={searchTerms}"; }]; # Don't know how to do w/ POST but I prefer GET anyways
iconURI = "https://search.tjkeller.xyz/static/themes/simple/img/favicon.svg"; # TODO doesn't seem to work
};
+ "Nix Packages" = {
+ urls = [{
+ template = "https://search.nixos.org/packages";
+ params = [
+ { name = "type"; value = "packages"; }
+ { name = "query"; value = "{searchTerms}"; }
+ ];
+ }];
+
+ icon = "${pkgs.nixos-icons}/share/icons/hicolor/scalable/apps/nix-snowflake.svg";
+ definedAliases = [ "@np" ];
+ };
};
default = "Timmy Search";
privateDefault = "Timmy Search";
@@ -44,6 +56,9 @@
"general.smoothScroll" = false;
#identity.fxaccounts.account.device.name = "timmy’s Firefox on nixos"; # HOSTNAME
};
+ workSettings = settings // {
+ "extensions.activeThemeID" = "firefox-compact-dark@mozilla.org"; # Use builtin dark theme instead of system theme
+ };
in {
Personal = {
id = 0;
@@ -56,6 +71,9 @@
Work = {
id = 1;
inherit search;
+ inherit userChrome;
+ inherit arkenfox;
+ settings = workSettings;
};
};
};