summaryrefslogtreecommitdiff
path: root/modules/home/firefox.nix
diff options
context:
space:
mode:
authorTim Keller <tjkeller.xyz>2025-02-06 22:03:18 -0600
committerTim Keller <tjkeller.xyz>2025-02-06 22:03:18 -0600
commitb03202e3ff9af9c961f813332c962913b6f81d22 (patch)
treea542f59b2c77c50622988155ce58d363c37f884b /modules/home/firefox.nix
parent56aa812441c150da6f27d7c848d3e3eb2ded4435 (diff)
downloadnixos-b03202e3ff9af9c961f813332c962913b6f81d22.tar.xz
nixos-b03202e3ff9af9c961f813332c962913b6f81d22.zip
pull repos if existing and firefox add search engine for nixos options
Diffstat (limited to 'modules/home/firefox.nix')
-rw-r--r--modules/home/firefox.nix19
1 files changed, 13 insertions, 6 deletions
diff --git a/modules/home/firefox.nix b/modules/home/firefox.nix
index 5e015ff..eff786c 100644
--- a/modules/home/firefox.nix
+++ b/modules/home/firefox.nix
@@ -9,21 +9,28 @@
search = {
engines = {
"Timmy Search" = {
- urls = [{ template = "https://search.tjkeller.xyz/search?q={searchTerms}"; }]; # Don't know how to do w/ POST but I prefer GET anyways
+ urls = [{
+ template = "https://search.tjkeller.xyz/search";
+ params = [ { name = "q"; value = "{searchTerms}}"; } ];
+ }];
iconURI = "https://search.tjkeller.xyz/static/themes/simple/img/favicon.svg"; # TODO doesn't seem to work
};
"Nix Packages" = {
urls = [{
template = "https://search.nixos.org/packages";
- params = [
- { name = "type"; value = "packages"; }
- { name = "query"; value = "{searchTerms}"; }
- ];
+ params = [ { name = "query"; value = "{searchTerms}"; } ];
}];
-
icon = "${pkgs.nixos-icons}/share/icons/hicolor/scalable/apps/nix-snowflake.svg";
definedAliases = [ "@np" ];
};
+ "NixOS Options" = {
+ urls = [{
+ template = "https://search.nixos.org/options";
+ params = [ { name = "query"; value = "{searchTerms}"; } ];
+ }];
+ icon = "${pkgs.nixos-icons}/share/icons/hicolor/scalable/apps/nix-snowflake.svg";
+ definedAliases = [ "@no" ];
+ };
};
default = "Timmy Search";
privateDefault = "Timmy Search";