summaryrefslogtreecommitdiff
path: root/modules/home/gtk-bookmarks.nix
diff options
context:
space:
mode:
authorTim Keller <tjkeller.xyz>2025-02-06 21:34:07 -0600
committerTim Keller <tjkeller.xyz>2025-02-06 21:34:07 -0600
commit56aa812441c150da6f27d7c848d3e3eb2ded4435 (patch)
tree6067aef1fa736cee5e88fb1db2bb36841ea567a9 /modules/home/gtk-bookmarks.nix
parent1ef7aa8333c0851d0ca5ae556b5f1d12fad87b08 (diff)
downloadnixos-56aa812441c150da6f27d7c848d3e3eb2ded4435.tar.xz
nixos-56aa812441c150da6f27d7c848d3e3eb2ded4435.zip
update bookmarks
Diffstat (limited to 'modules/home/gtk-bookmarks.nix')
-rw-r--r--modules/home/gtk-bookmarks.nix17
1 files changed, 17 insertions, 0 deletions
diff --git a/modules/home/gtk-bookmarks.nix b/modules/home/gtk-bookmarks.nix
new file mode 100644
index 0000000..067543d
--- /dev/null
+++ b/modules/home/gtk-bookmarks.nix
@@ -0,0 +1,17 @@
+{ config, lib, userDetails, ... }: {
+ options = {
+ additional-gtk-bookmarks = lib.mkOption {
+ type = with lib.types; listOf str;
+ default = [];
+ description = "gtk bookmarks for file managers, etc.";
+ };
+ };
+
+ config = {
+ gtk.gtk3.bookmarks = with userDetails; [
+ "file://${home.downloads} Downloads"
+ "file://${home.documents} Documents"
+ "file://${home.pictures} Pictures"
+ ] ++ config.additional-gtk-bookmarks;
+ };
+}