summaryrefslogtreecommitdiff
path: root/modules/home/initial-home-setup.nix
diff options
context:
space:
mode:
authorTim Keller <tjkeller.xyz>2025-05-05 13:25:38 -0500
committerTim Keller <tjkeller.xyz>2025-05-05 13:25:38 -0500
commit1969493257f4644c3b105b3fc2c82a445a2ae664 (patch)
treefa14e1d54a47b45895a232cec1ae6641af717a05 /modules/home/initial-home-setup.nix
parentf59d51611cbe61ff492bd836cea29a7aa33a294c (diff)
downloadnixos-1969493257f4644c3b105b3fc2c82a445a2ae664.tar.xz
nixos-1969493257f4644c3b105b3fc2c82a445a2ae664.zip
use xdg-userdirs functionality
Diffstat (limited to 'modules/home/initial-home-setup.nix')
-rw-r--r--modules/home/initial-home-setup.nix4
1 files changed, 2 insertions, 2 deletions
diff --git a/modules/home/initial-home-setup.nix b/modules/home/initial-home-setup.nix
index 6aa6ac7..4132386 100644
--- a/modules/home/initial-home-setup.nix
+++ b/modules/home/initial-home-setup.nix
@@ -15,8 +15,8 @@
export PATH="$HOME/.local/bin/misc:$PATH"
run mimewiz -i # already verbose
'';
- createDirs = with userDetails.home; lib.hm.dag.entryAfter ["writeBoundary"] ''
- run mkdir -p $VERBOSE_ARG "${downloads}" "${documents}" "${pictures}"
+ createDirs = lib.hm.dag.entryAfter ["writeBoundary"] ''
+ run mkdir -p $VERBOSE_ARG ${ lib.concatStringsSep " " (lib.attrValues userDetails.userDirs) }
'';
};
}