summaryrefslogtreecommitdiff
path: root/modules/home/theme.nix
diff options
context:
space:
mode:
authorTim Keller <tjkeller.xyz>2025-04-10 22:54:58 -0500
committerTim Keller <tjkeller.xyz>2025-04-10 22:54:58 -0500
commit0b69050f491804346bd9c6708f016f493da39117 (patch)
tree30f437b123e1bec4cf84cfa4927d61d60244ee03 /modules/home/theme.nix
parente930cef113f65722d9b859ffc44b0b63622e41e0 (diff)
downloadnixos-0b69050f491804346bd9c6708f016f493da39117.tar.xz
nixos-0b69050f491804346bd9c6708f016f493da39117.zip
gtk font host config instead of just using sans serif and change gtk font size
Diffstat (limited to 'modules/home/theme.nix')
-rw-r--r--modules/home/theme.nix15
1 files changed, 14 insertions, 1 deletions
diff --git a/modules/home/theme.nix b/modules/home/theme.nix
index a1c4f9b..bc8532e 100644
--- a/modules/home/theme.nix
+++ b/modules/home/theme.nix
@@ -40,6 +40,18 @@ in {
default = "CommitMono";
description = "default monospace font";
};
+ gtk = {
+ name = lib.mkOption {
+ type = lib.types.str;
+ default = "sans-serif";
+ description = "default gtk font";
+ };
+ size = lib.mkOption {
+ type = lib.types.int;
+ default = null;
+ description = "default gtk font size";
+ };
+ };
};
};
@@ -55,7 +67,8 @@ in {
name = transformColorValue config.theme.mint.icons.color;
};
font = {
- name = config.theme.font.sansSerif;
+ name = config.theme.font.gtk.name;
+ size = config.theme.font.gtk.size;
};
cursorTheme = {
name = "Adwaita";