summaryrefslogtreecommitdiff
path: root/modules/home/theme.nix
diff options
context:
space:
mode:
authorTim Keller <tjkeller.xyz>2025-04-12 17:28:05 -0500
committerTim Keller <tjkeller.xyz>2025-04-12 17:28:05 -0500
commit2024f141ae579131e9c88d79056d8dc921d3551d (patch)
treebcc81d6bf3f8325219d05e98dd4622c55c715086 /modules/home/theme.nix
parent81b0fa433585bd0899f1e7c0116bd108f23375b9 (diff)
downloadnixos-2024f141ae579131e9c88d79056d8dc921d3551d.tar.xz
nixos-2024f141ae579131e9c88d79056d8dc921d3551d.zip
cursor size option
Diffstat (limited to 'modules/home/theme.nix')
-rw-r--r--modules/home/theme.nix8
1 files changed, 8 insertions, 0 deletions
diff --git a/modules/home/theme.nix b/modules/home/theme.nix
index bc8532e..4edaffa 100644
--- a/modules/home/theme.nix
+++ b/modules/home/theme.nix
@@ -53,6 +53,13 @@ in {
};
};
};
+ theme.cursor = {
+ size = lib.mkOption {
+ type = lib.types.int;
+ default = null;
+ description = "gtk cursor size";
+ };
+ };
};
config = {
@@ -72,6 +79,7 @@ in {
};
cursorTheme = {
name = "Adwaita";
+ size = config.theme.cursor.size;
};
gtk2.configLocation = "${config.xdg.configHome}/gtk-2.0/gtkrc";
};