summaryrefslogtreecommitdiff
path: root/modules/hosts/T495/configuration.nix
diff options
context:
space:
mode:
authorTim Keller <tjkeller.xyz>2024-11-05 10:00:57 -0600
committerTim Keller <tjkeller.xyz>2024-11-05 10:00:57 -0600
commit78d758b4b22e1150b32f3643ef5a9f04f76abf26 (patch)
tree0e770f821caa8040ccc4ff383824c92fe5641b50 /modules/hosts/T495/configuration.nix
parente2796bbd4ff55fcaacbceddd996890593c2b762a (diff)
downloadnixos-78d758b4b22e1150b32f3643ef5a9f04f76abf26.tar.xz
nixos-78d758b4b22e1150b32f3643ef5a9f04f76abf26.zip
fix bugs for t495 and cleanup
Diffstat (limited to 'modules/hosts/T495/configuration.nix')
-rw-r--r--modules/hosts/T495/configuration.nix18
1 files changed, 17 insertions, 1 deletions
diff --git a/modules/hosts/T495/configuration.nix b/modules/hosts/T495/configuration.nix
index 9983a21..8e10260 100644
--- a/modules/hosts/T495/configuration.nix
+++ b/modules/hosts/T495/configuration.nix
@@ -4,11 +4,27 @@
./wg.nix
];
networking.hostName = "T495";
- grub.mode = "efi";
+ # Use systemd-boot instead of grub
+ # grub does not recognize fs
+ grub.enable = false;
+ boot.loader = {
+ systemd-boot.enable = true;
+ efi.canTouchEfiVariables = true;
+ };
+
+ # Enable extra software pkgs
+ software = {
+ desktop.extra.enable = true;
+ dev.extra.enable = true;
+ };
environment.systemPackages = with pkgs; [
input-leap
];
+ docker.enable = true;
+
+ # Enable network drives
+ fs.networkFS.enable = true;
system.stateVersion = "24.05";
}