summaryrefslogtreecommitdiff
path: root/modules/hosts/hp-envy-office/hardware-configuration.nix
diff options
context:
space:
mode:
authorTim Keller <tjkeller.xyz>2025-01-06 13:08:05 -0600
committerTim Keller <tjkeller.xyz>2025-01-06 13:08:05 -0600
commit9a92c148a04b66a9d5f665dc13ea60a8fbf0dd28 (patch)
treeafa5a0c4ed4ced0cf0ab2d4098c50dd235e61731 /modules/hosts/hp-envy-office/hardware-configuration.nix
parent1835aa04051f2f0c41017423f2bcba6c549f26b0 (diff)
downloadnixos-9a92c148a04b66a9d5f665dc13ea60a8fbf0dd28.tar.xz
nixos-9a92c148a04b66a9d5f665dc13ea60a8fbf0dd28.zip
add new host for office pc and automount func config
Diffstat (limited to 'modules/hosts/hp-envy-office/hardware-configuration.nix')
-rw-r--r--modules/hosts/hp-envy-office/hardware-configuration.nix48
1 files changed, 48 insertions, 0 deletions
diff --git a/modules/hosts/hp-envy-office/hardware-configuration.nix b/modules/hosts/hp-envy-office/hardware-configuration.nix
new file mode 100644
index 0000000..22a8c24
--- /dev/null
+++ b/modules/hosts/hp-envy-office/hardware-configuration.nix
@@ -0,0 +1,48 @@
+# Do not modify this file! It was generated by ‘nixos-generate-config’
+# and may be overwritten by future invocations. Please make changes
+# to /etc/nixos/configuration.nix instead.
+{ config, lib, pkgs, modulesPath, ... }:
+
+{
+ imports =
+ [ (modulesPath + "/installer/scan/not-detected.nix")
+ ];
+
+ boot.initrd.availableKernelModules = [ "xhci_pci" "ahci" "ums_realtek" "usb_storage" "usbhid" "sd_mod" "sr_mod" ];
+ boot.initrd.kernelModules = [ ];
+ boot.kernelModules = [ ];
+ boot.extraModulePackages = [ ];
+
+ fileSystems."/" =
+ { device = "/dev/disk/by-uuid/5749d84b-690b-43a2-b834-f94675003189";
+ fsType = "btrfs";
+ options = [ "subvol=@" ];
+ };
+
+ boot.initrd.luks.devices."cryptroot".device = "/dev/disk/by-uuid/4a617e54-4800-4474-b1fd-3bca5f66e55a";
+
+ fileSystems."/home" =
+ { device = "/dev/disk/by-uuid/5749d84b-690b-43a2-b834-f94675003189";
+ fsType = "btrfs";
+ options = [ "subvol=@home" ];
+ };
+
+ fileSystems."/boot" =
+ { device = "/dev/disk/by-uuid/5E93-7CE3";
+ fsType = "vfat";
+ options = [ "fmask=0022" "dmask=0022" ];
+ };
+
+ swapDevices = [ ];
+
+ # Enables DHCP on each ethernet and wireless interface. In case of scripted networking
+ # (the default) this is the recommended approach. When using systemd-networkd it's
+ # still possible to use this option, but it's recommended to use it in conjunction
+ # with explicit per-interface declarations with `networking.interfaces.<interface>.useDHCP`.
+ networking.useDHCP = lib.mkDefault true;
+ # networking.interfaces.enp3s0.useDHCP = lib.mkDefault true;
+ # networking.interfaces.wlp2s0.useDHCP = lib.mkDefault true;
+
+ nixpkgs.hostPlatform = lib.mkDefault "x86_64-linux";
+ hardware.cpu.intel.updateMicrocode = lib.mkDefault config.hardware.enableRedistributableFirmware;
+}