summaryrefslogtreecommitdiff
path: root/modules/hosts/libreX60/configuration.nix
diff options
context:
space:
mode:
authorTim Keller <tjkeller.xyz>2025-04-10 22:26:59 -0500
committerTim Keller <tjkeller.xyz>2025-04-10 22:26:59 -0500
commite930cef113f65722d9b859ffc44b0b63622e41e0 (patch)
tree95f9ed8af3de09e21ebd05c416e95fe0f416536e /modules/hosts/libreX60/configuration.nix
parent1ab92dfc79ab95c152f7cda68017401e41ce363b (diff)
downloadnixos-e930cef113f65722d9b859ffc44b0b63622e41e0.tar.xz
nixos-e930cef113f65722d9b859ffc44b0b63622e41e0.zip
tamzen wrapper for st on librex60
Diffstat (limited to 'modules/hosts/libreX60/configuration.nix')
-rw-r--r--modules/hosts/libreX60/configuration.nix13
1 files changed, 13 insertions, 0 deletions
diff --git a/modules/hosts/libreX60/configuration.nix b/modules/hosts/libreX60/configuration.nix
index d736763..e1fa6fd 100644
--- a/modules/hosts/libreX60/configuration.nix
+++ b/modules/hosts/libreX60/configuration.nix
@@ -19,5 +19,18 @@
# i915 Gpu requires intel driver
services.xserver.videoDrivers = [ "intel" ];
+ # Tamzen font in st
+ nixpkgs.overlays = [
+ (final: prev: {
+ st = prev.st.overrideAttrs (old: {
+ buildInputs = old.buildInputs or [] ++ [ pkgs.makeWrapper ];
+ postInstall = old.postInstall or "" + ''
+ wrapProgram $out/bin/st \
+ --add-flags '-fTamzen:pixelsize=14'
+ '';
+ });
+ })
+ ];
+
system.stateVersion = "24.11";
}