summaryrefslogtreecommitdiff
path: root/modules/hosts/libreX60/hardware-configuration.nix
diff options
context:
space:
mode:
authorTim Keller <tjkeller.xyz>2025-04-09 21:09:31 -0500
committerTim Keller <tjkeller.xyz>2025-04-09 21:09:31 -0500
commitd82edfcf8a36f798c73c38dddada6a70a4e1c009 (patch)
tree8e793e8dfd555339736172f32f688dd8c6cffa6b /modules/hosts/libreX60/hardware-configuration.nix
parentd54288963941d5aded78d8bf34c198ee78f5ec24 (diff)
downloadnixos-d82edfcf8a36f798c73c38dddada6a70a4e1c009.tar.xz
nixos-d82edfcf8a36f798c73c38dddada6a70a4e1c009.zip
libreX60 configuration now that xf86videointel is fixed!
Diffstat (limited to 'modules/hosts/libreX60/hardware-configuration.nix')
-rw-r--r--modules/hosts/libreX60/hardware-configuration.nix46
1 files changed, 46 insertions, 0 deletions
diff --git a/modules/hosts/libreX60/hardware-configuration.nix b/modules/hosts/libreX60/hardware-configuration.nix
new file mode 100644
index 0000000..b0a7868
--- /dev/null
+++ b/modules/hosts/libreX60/hardware-configuration.nix
@@ -0,0 +1,46 @@
+# Do not modify this file! It was generated by ‘nixos-generate-config’
+# and may be overwritten by future invocations. Please make changes
+# to /etc/nixos/configuration.nix instead.
+{ config, lib, pkgs, modulesPath, ... }:
+
+{
+ imports =
+ [ (modulesPath + "/installer/scan/not-detected.nix")
+ ];
+
+ boot.initrd.availableKernelModules = [ "uhci_hcd" "ehci_pci" "ata_piix" "ahci" "firewire_ohci" "usb_storage" "sd_mod" "sdhci_pci" ];
+ boot.initrd.kernelModules = [ ];
+ boot.kernelModules = [ "kvm-intel" ];
+ boot.extraModulePackages = [ ];
+
+ fileSystems."/" =
+ { device = "/dev/disk/by-uuid/91572803-436d-4f43-b41f-dfba2103752e";
+ fsType = "btrfs";
+ options = [ "subvol=@" ];
+ };
+
+ fileSystems."/home" =
+ { device = "/dev/disk/by-uuid/91572803-436d-4f43-b41f-dfba2103752e";
+ fsType = "btrfs";
+ options = [ "subvol=@home" ];
+ };
+
+ fileSystems."/boot" =
+ { device = "/dev/disk/by-uuid/F618-D6C2";
+ fsType = "vfat";
+ options = [ "fmask=0022" "dmask=0022" ];
+ };
+
+ swapDevices = [ ];
+
+ # Enables DHCP on each ethernet and wireless interface. In case of scripted networking
+ # (the default) this is the recommended approach. When using systemd-networkd it's
+ # still possible to use this option, but it's recommended to use it in conjunction
+ # with explicit per-interface declarations with `networking.interfaces.<interface>.useDHCP`.
+ networking.useDHCP = lib.mkDefault true;
+ networking.interfaces.enp1s0.useDHCP = lib.mkDefault true;
+ networking.interfaces.wlp2s0.useDHCP = lib.mkDefault true;
+
+ nixpkgs.hostPlatform = lib.mkDefault "x86_64-linux";
+ hardware.cpu.intel.updateMicrocode = lib.mkDefault config.hardware.enableRedistributableFirmware;
+}