summaryrefslogtreecommitdiff
path: root/modules/root/filesystems.nix
diff options
context:
space:
mode:
authorTim Keller <tjkeller.xyz>2025-01-05 16:19:45 -0600
committerTim Keller <tjkeller.xyz>2025-01-05 16:19:45 -0600
commit1835aa04051f2f0c41017423f2bcba6c549f26b0 (patch)
treeb5f26e29032e9084b27eeb0688c7a3a9bb0df57f /modules/root/filesystems.nix
parentd0faef2f53e2e5195b2acc7cc7bba898bd7cd05b (diff)
downloadnixos-1835aa04051f2f0c41017423f2bcba6c549f26b0.tar.xz
nixos-1835aa04051f2f0c41017423f2bcba6c549f26b0.zip
overhual
Diffstat (limited to 'modules/root/filesystems.nix')
-rw-r--r--modules/root/filesystems.nix23
1 files changed, 0 insertions, 23 deletions
diff --git a/modules/root/filesystems.nix b/modules/root/filesystems.nix
deleted file mode 100644
index 1784feb..0000000
--- a/modules/root/filesystems.nix
+++ /dev/null
@@ -1,23 +0,0 @@
-{ lib, config, ... } :
-let
- mkNetworkFileSystem = device : {
- device = "${device}";
- fsType = "nfs";
- options = [ "noauto" "defaults" ];
- };
-in {
- options = {
- fs.networkFS.enable = lib.mkEnableOption "enable network shares";
- };
- config = {
- fileSystems = lib.mkIf config.fs.networkFS.enable {
- "/media/Storage/Media" = mkNetworkFileSystem "truenas-home:/mnt/Storage/Media";
- "/media/Storage/Backups" = mkNetworkFileSystem "truenas-home:/mnt/Storage/Backups";
- "/media/Storage/Tapes" = mkNetworkFileSystem "truenas-home:/mnt/Storage/Backups/Tapes";
- "/media/Family Photos" = mkNetworkFileSystem "truenas-home:/mnt/Media/Photos";
- "/media/chexx/chexx" = mkNetworkFileSystem "truenas-office:/mnt/Storage/chexx";
- "/media/chexx/tkdocs" = mkNetworkFileSystem "truenas-office:/mnt/Storage/Users/Tim-Keller";
- "/media/chexx/scans" = mkNetworkFileSystem "truenas-office:/mnt/Storage/Scans";
- };
- };
-}