summaryrefslogtreecommitdiff
path: root/modules/root/grub.nix
diff options
context:
space:
mode:
authorTim Keller <tjkeller.xyz>2025-01-05 16:19:45 -0600
committerTim Keller <tjkeller.xyz>2025-01-05 16:19:45 -0600
commit1835aa04051f2f0c41017423f2bcba6c549f26b0 (patch)
treeb5f26e29032e9084b27eeb0688c7a3a9bb0df57f /modules/root/grub.nix
parentd0faef2f53e2e5195b2acc7cc7bba898bd7cd05b (diff)
downloadnixos-1835aa04051f2f0c41017423f2bcba6c549f26b0.tar.xz
nixos-1835aa04051f2f0c41017423f2bcba6c549f26b0.zip
overhual
Diffstat (limited to 'modules/root/grub.nix')
-rw-r--r--modules/root/grub.nix26
1 files changed, 0 insertions, 26 deletions
diff --git a/modules/root/grub.nix b/modules/root/grub.nix
deleted file mode 100644
index 4e6a5f5..0000000
--- a/modules/root/grub.nix
+++ /dev/null
@@ -1,26 +0,0 @@
-{ lib, config, ... }: {
- options = {
- grub.enable = lib.mkEnableOption "enables grub bootloader";
- grub.mode = lib.mkOption {
- type = lib.types.enum [ "efi" "bios" ];
- default = "efi";
- description = "grub mode efi or bios";
- };
- grub.biosDevice = lib.mkOption {
- type = lib.types.str;
- description = "device to install grub on";
- };
- };
-
- config = lib.mkIf config.grub.enable {
- boot.loader = {
- grub = {
- enable = true;
- efiSupport = config.grub.mode == "efi";
- efiInstallAsRemovable = config.grub.mode == "efi";
- device = if config.grub.mode == "bios" then config.grub.biosDevice else "nodev";
- };
- efi.efiSysMountPoint = "/boot/efi";
- };
- };
-}