summaryrefslogtreecommitdiff
path: root/modules/root/software.nix
diff options
context:
space:
mode:
authorTim Keller <tjkeller.xyz>2025-01-05 16:19:45 -0600
committerTim Keller <tjkeller.xyz>2025-01-05 16:19:45 -0600
commit1835aa04051f2f0c41017423f2bcba6c549f26b0 (patch)
treeb5f26e29032e9084b27eeb0688c7a3a9bb0df57f /modules/root/software.nix
parentd0faef2f53e2e5195b2acc7cc7bba898bd7cd05b (diff)
downloadnixos-1835aa04051f2f0c41017423f2bcba6c549f26b0.tar.xz
nixos-1835aa04051f2f0c41017423f2bcba6c549f26b0.zip
overhual
Diffstat (limited to 'modules/root/software.nix')
-rw-r--r--modules/root/software.nix102
1 files changed, 0 insertions, 102 deletions
diff --git a/modules/root/software.nix b/modules/root/software.nix
deleted file mode 100644
index fcd3c00..0000000
--- a/modules/root/software.nix
+++ /dev/null
@@ -1,102 +0,0 @@
-{ pkgs, lib, config, ... }: {
- options = {
- software = {
- desktop = {
- enable = lib.mkEnableOption "enables desktop apps";
- extra.enable = lib.mkEnableOption "enables extra desktop apps";
- };
- dev = {
- enable = lib.mkEnableOption "enables development utilities";
- extra.enable = lib.mkEnableOption "enables extra development utilities";
- };
- utils = {
- enable = lib.mkEnableOption "enables general utilities";
- };
- };
- };
-
- config = {
- environment.systemPackages = with pkgs; pkgs.lib.optionals config.software.desktop.enable [
- # Desktop
- alacritty
- arandr
- dmenu
- firefox
- libnotify
- mpv
- pavucontrol
- pcmanfm
- redshift
- sxiv
- wpa_supplicant_gui
- zathura
- ] ++ pkgs.lib.optionals config.software.desktop.extra.enable [
- # Desktop Extra
- geeqie
- gimp
- inkscape
- jellyfin-mpv-shim
- libreoffice
- localsend
- qbittorrent
- qdirstat
- remmina
- thunderbird
- ungoogled-chromium
- ] ++ pkgs.lib.optionals config.software.dev.enable [
- # Development
- dash # TODO should be default /bin/sh
- entr
- gcc
- git
- gnumake
- jq
- lm_sensors
- nmap
- openssl
- pkg-config
- python3
- sassc
- sslscan
- wget
- ] ++ pkgs.lib.optionals config.software.dev.extra.enable [
- # Development Extra
- android-tools
- cargo
- hugo
- lua
- uhubctl
- wireguard-tools
- ] ++ pkgs.lib.optionals config.software.utils.enable [
- # Utilities
- age
- cryptsetup
- fastfetch
- htop
- light
- neovim
- p7zip
- powertop
- pv
- rsync
- screen
- scrot
- smartmontools
- sops
- stress
- testdisk
- tmux
- xxHash
- (callPackage ../../derivations/lowbat {})
- (callPackage ../../derivations/pavolctld {})
- ];
-
- # More desktop
- programs.dconf.enable = config.software.desktop.enable; # For home-manager to configure gtk TODO this should be there instead
-
- # More utilities
- programs.zsh.enable = config.software.utils.enable;
- users.defaultUserShell = lib.mkIf config.software.utils.enable pkgs.zsh;
- services.openssh.enable = config.software.utils.enable;
- };
-}