summaryrefslogtreecommitdiff
path: root/modules/root/software/desktop.nix
diff options
context:
space:
mode:
authorTim Keller <tjk@tjkeller.xyz>2024-10-02 22:07:10 -0500
committerTim Keller <tjk@tjkeller.xyz>2024-10-02 22:07:10 -0500
commit4730b215fdc4095800fedfdf690c12fec994bb6b (patch)
tree3c746ece0089625a8093d4ae6bf1149ea903b7dc /modules/root/software/desktop.nix
parent34b0bb8df42194a0ea433592e3cac27546f0af4e (diff)
downloadnixos-4730b215fdc4095800fedfdf690c12fec994bb6b.tar.xz
nixos-4730b215fdc4095800fedfdf690c12fec994bb6b.zip
more reorganizing and modularizing
Diffstat (limited to 'modules/root/software/desktop.nix')
-rw-r--r--modules/root/software/desktop.nix22
1 files changed, 22 insertions, 0 deletions
diff --git a/modules/root/software/desktop.nix b/modules/root/software/desktop.nix
new file mode 100644
index 0000000..195d742
--- /dev/null
+++ b/modules/root/software/desktop.nix
@@ -0,0 +1,22 @@
+{ pkgs, lib, config, ... }: {
+ options = {
+ software.desktop.enable = lib.mkEnableOption "enables desktop apps";
+ };
+
+ config = lib.mkIf config.software.desktop.enable {
+ programs.dconf.enable = true; # For home-manager to configure gtk
+
+ environment.systemPackages = with pkgs; [
+ alacritty
+ arandr
+ dmenu
+ firefox
+ mpv
+ pavucontrol
+ pcmanfm
+ redshift
+ sxiv
+ zathura
+ ];
+ };
+}