summaryrefslogtreecommitdiff
path: root/modules/root/software/dev.nix
diff options
context:
space:
mode:
authorTim Keller <tjk@tjkeller.xyz>2024-10-02 22:07:10 -0500
committerTim Keller <tjk@tjkeller.xyz>2024-10-02 22:07:10 -0500
commit4730b215fdc4095800fedfdf690c12fec994bb6b (patch)
tree3c746ece0089625a8093d4ae6bf1149ea903b7dc /modules/root/software/dev.nix
parent34b0bb8df42194a0ea433592e3cac27546f0af4e (diff)
downloadnixos-4730b215fdc4095800fedfdf690c12fec994bb6b.tar.xz
nixos-4730b215fdc4095800fedfdf690c12fec994bb6b.zip
more reorganizing and modularizing
Diffstat (limited to 'modules/root/software/dev.nix')
-rw-r--r--modules/root/software/dev.nix23
1 files changed, 23 insertions, 0 deletions
diff --git a/modules/root/software/dev.nix b/modules/root/software/dev.nix
new file mode 100644
index 0000000..b0dabcc
--- /dev/null
+++ b/modules/root/software/dev.nix
@@ -0,0 +1,23 @@
+{ pkgs, lib, config, ... }: {
+ options = {
+ software.dev.enable = lib.mkEnableOption "enables dev apps";
+ };
+
+ config = lib.mkIf config.software.dev.enable {
+ environment.systemPackages = with pkgs; [
+ dash # TODO should be default /bin/sh
+ entr
+ gcc
+ git
+ gnumake
+ jq
+ lm_sensors
+ nmap
+ openssl
+ python3
+ sassc
+ sslscan
+ wget
+ ];
+ };
+}