summaryrefslogtreecommitdiff
path: root/modules/root/software/docker.nix
diff options
context:
space:
mode:
authorTim Keller <tjkeller.xyz>2025-01-05 16:19:45 -0600
committerTim Keller <tjkeller.xyz>2025-01-05 16:19:45 -0600
commit1835aa04051f2f0c41017423f2bcba6c549f26b0 (patch)
treeb5f26e29032e9084b27eeb0688c7a3a9bb0df57f /modules/root/software/docker.nix
parentd0faef2f53e2e5195b2acc7cc7bba898bd7cd05b (diff)
downloadnixos-1835aa04051f2f0c41017423f2bcba6c549f26b0.tar.xz
nixos-1835aa04051f2f0c41017423f2bcba6c549f26b0.zip
overhual
Diffstat (limited to 'modules/root/software/docker.nix')
-rw-r--r--modules/root/software/docker.nix21
1 files changed, 21 insertions, 0 deletions
diff --git a/modules/root/software/docker.nix b/modules/root/software/docker.nix
new file mode 100644
index 0000000..bf1898c
--- /dev/null
+++ b/modules/root/software/docker.nix
@@ -0,0 +1,21 @@
+{ pkgs, lib, config, userDetails, ... }: {
+ options = {
+ software.development.docker = {
+ enable = lib.mkEnableOption "enables docker";
+ btrfsSupport = lib.mkEnableOption "changes docker storageDriver to btrfs";
+ };
+ };
+
+ config = lib.mkIf config.software.development.docker.enable {
+ virtualisation.docker = {
+ enable = true;
+ storageDriver = lib.mkIf config.software.development.docker.btrfsSupport "btrfs";
+ };
+
+ environment.systemPackages = with pkgs; [
+ docker-compose
+ ];
+
+ users.groups.docker.members = [ userDetails.username ];
+ };
+}