summaryrefslogtreecommitdiff
path: root/modules/root/software/system.nix
diff options
context:
space:
mode:
authorTim Keller <tjkeller.xyz>2025-01-05 16:19:45 -0600
committerTim Keller <tjkeller.xyz>2025-01-05 16:19:45 -0600
commit1835aa04051f2f0c41017423f2bcba6c549f26b0 (patch)
treeb5f26e29032e9084b27eeb0688c7a3a9bb0df57f /modules/root/software/system.nix
parentd0faef2f53e2e5195b2acc7cc7bba898bd7cd05b (diff)
downloadnixos-1835aa04051f2f0c41017423f2bcba6c549f26b0.tar.xz
nixos-1835aa04051f2f0c41017423f2bcba6c549f26b0.zip
overhual
Diffstat (limited to 'modules/root/software/system.nix')
-rw-r--r--modules/root/software/system.nix11
1 files changed, 11 insertions, 0 deletions
diff --git a/modules/root/software/system.nix b/modules/root/software/system.nix
new file mode 100644
index 0000000..18cc8dd
--- /dev/null
+++ b/modules/root/software/system.nix
@@ -0,0 +1,11 @@
+{ pkgs, ... }: {
+ environment.systemPackages = with pkgs; [
+ age # Secrets
+ cryptsetup
+ dash # TODO should be default /bin/sh
+ exfat
+ git # Needed for home-manager
+ python3
+ sops # Secrets
+ ];
+}