summaryrefslogtreecommitdiff
path: root/modules/root/tlp.nix
diff options
context:
space:
mode:
authorTim Keller <tjkeller.xyz>2024-11-05 10:00:57 -0600
committerTim Keller <tjkeller.xyz>2024-11-05 10:00:57 -0600
commit78d758b4b22e1150b32f3643ef5a9f04f76abf26 (patch)
tree0e770f821caa8040ccc4ff383824c92fe5641b50 /modules/root/tlp.nix
parente2796bbd4ff55fcaacbceddd996890593c2b762a (diff)
downloadnixos-78d758b4b22e1150b32f3643ef5a9f04f76abf26.tar.xz
nixos-78d758b4b22e1150b32f3643ef5a9f04f76abf26.zip
fix bugs for t495 and cleanup
Diffstat (limited to 'modules/root/tlp.nix')
-rw-r--r--modules/root/tlp.nix9
1 files changed, 9 insertions, 0 deletions
diff --git a/modules/root/tlp.nix b/modules/root/tlp.nix
new file mode 100644
index 0000000..3414c03
--- /dev/null
+++ b/modules/root/tlp.nix
@@ -0,0 +1,9 @@
+{ lib, config, ... }: {
+ options = {
+ tlp.enable = lib.mkEnableOption "enables tlp";
+ };
+
+ config = lib.mkIf config.tlp.enable {
+ services.tlp.enable = true;
+ };
+}