summaryrefslogtreecommitdiff
path: root/modules/root/zsh.nix
diff options
context:
space:
mode:
authorTim Keller <tjkeller.xyz>2025-01-05 16:19:45 -0600
committerTim Keller <tjkeller.xyz>2025-01-05 16:19:45 -0600
commit1835aa04051f2f0c41017423f2bcba6c549f26b0 (patch)
treeb5f26e29032e9084b27eeb0688c7a3a9bb0df57f /modules/root/zsh.nix
parentd0faef2f53e2e5195b2acc7cc7bba898bd7cd05b (diff)
downloadnixos-1835aa04051f2f0c41017423f2bcba6c549f26b0.tar.xz
nixos-1835aa04051f2f0c41017423f2bcba6c549f26b0.zip
overhual
Diffstat (limited to 'modules/root/zsh.nix')
-rw-r--r--modules/root/zsh.nix10
1 files changed, 10 insertions, 0 deletions
diff --git a/modules/root/zsh.nix b/modules/root/zsh.nix
new file mode 100644
index 0000000..697cb4c
--- /dev/null
+++ b/modules/root/zsh.nix
@@ -0,0 +1,10 @@
+{ lib, config, pkgs, ... }: {
+ options = {
+ zsh.enable = lib.mkEnableOption "use zsh as default shell";
+ };
+
+ config = lib.mkIf config.zsh.enable {
+ programs.zsh.enable = true;
+ users.defaultUserShell = pkgs.zsh;
+ };
+}