summaryrefslogtreecommitdiff
path: root/modules/x11/default.nix
diff options
context:
space:
mode:
authorTim Keller <tjk@tjkeller.xyz>2024-10-02 22:07:10 -0500
committerTim Keller <tjk@tjkeller.xyz>2024-10-02 22:07:10 -0500
commit4730b215fdc4095800fedfdf690c12fec994bb6b (patch)
tree3c746ece0089625a8093d4ae6bf1149ea903b7dc /modules/x11/default.nix
parent34b0bb8df42194a0ea433592e3cac27546f0af4e (diff)
downloadnixos-4730b215fdc4095800fedfdf690c12fec994bb6b.tar.xz
nixos-4730b215fdc4095800fedfdf690c12fec994bb6b.zip
more reorganizing and modularizing
Diffstat (limited to 'modules/x11/default.nix')
-rw-r--r--modules/x11/default.nix30
1 files changed, 0 insertions, 30 deletions
diff --git a/modules/x11/default.nix b/modules/x11/default.nix
deleted file mode 100644
index 8fa1d27..0000000
--- a/modules/x11/default.nix
+++ /dev/null
@@ -1,30 +0,0 @@
-{ pkgs, lib, config, ... }: {
- options = {
- xserver.enable = lib.mkEnableOption "enables xserver";
- };
-
- config = lib.mkIf config.xserver.enable {
- services.xserver.enable = true;
- services.xserver.displayManager.startx.enable = true;
- services.libinput.enable = true; # Enable touchpad support
-
- environment.systemPackages = with pkgs; [
- unclutter
- xcape
- xclip
- xdotool
- xorg.setxkbmap
- xorg.xinput
- xorg.xkill
- xorg.xrandr
- xorg.xset
- xwallpaper
- # Patch startx to be compliant with xdg base dir spec
- (xorg.xinit.overrideAttrs (old: rec {
- patches = [
- ./xinit-startx-xdg.patch
- ];
- }))
- ];
- };
-}