diff options
Diffstat (limited to 'flake.nix')
-rw-r--r-- | flake.nix | 12 |
1 files changed, 6 insertions, 6 deletions
@@ -8,12 +8,10 @@ rec { url = "github:Mic92/sops-nix"; inputs.nixpkgs.follows = "nixpkgs"; }; - home-manager = { url = "github:nix-community/home-manager/release-24.11"; inputs.nixpkgs.follows = "nixpkgs"; }; - arkenfox = { url = "github:dwarfmaster/arkenfox-nixos"; inputs.nixpkgs.follows = "nixpkgs"; @@ -26,12 +24,14 @@ rec { pkgs = nixpkgs.legacyPackages.${system}; userDetails = { username = "timmy"; - home.root = "/home/timmy"; - home.downloads = "/home/timmy/dls"; - home.documents = "/home/timmy/docs"; - home.pictures = "/home/timmy/pics"; email = "tjkeller.xyz"; fullname = "Tim Keller"; + home = with userDetails; with home; { + root = "/home/${username}"; + downloads = "${root}/dls"; + documents = "${root}/docs"; + pictures = "${root}/pics"; + }; }; homeStateVersion = "24.05"; # Lowest of systems is fine mkNixosConfiguration = hostname: nixpkgs.lib.nixosSystem { |