diff options
Diffstat (limited to 'flake.nix')
-rw-r--r-- | flake.nix | 23 |
1 files changed, 18 insertions, 5 deletions
@@ -8,21 +8,34 @@ url = "github:nix-community/home-manager/release-24.05"; inputs.nixpkgs.follows = "nixpkgs"; }; + + arkenfox = { + url = "github:dwarfmaster/arkenfox-nixos"; + inputs.nixpkgs.follows = "nixpkgs"; + #inputs.home-manager.follows = "home-manager"; + }; }; - outputs = { nixpkgs, home-manager, ... }: + outputs = { nixpkgs, home-manager, arkenfox, ... }@inputs : # HOSTNAME NIXOS let system = "x86_64-linux"; + pkgs = nixpkgs.legacyPackages.${system}; in { - nixosConfigurations.nixos = nixpkgs.lib.nixosSystem { + nixosConfigurations.nixos = nixpkgs.lib.nixosSystem { inherit system; - modules = [ ./configuration.nix ]; + specialArgs = { inherit inputs; }; + modules = [ + ./configuration.nix + ]; }; homeConfigurations.timmy = home-manager.lib.homeManagerConfiguration { - pkgs = nixpkgs.legacyPackages.${system}; - modules = [ ./home.nix ]; + inherit pkgs; + modules = [ + ./home.nix + inputs.arkenfox.hmModules.arkenfox + ]; }; }; } |