summaryrefslogtreecommitdiff
path: root/modules/home/chrome.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/home/chrome.nix')
-rw-r--r--modules/home/chrome.nix28
1 files changed, 28 insertions, 0 deletions
diff --git a/modules/home/chrome.nix b/modules/home/chrome.nix
new file mode 100644
index 0000000..976a74b
--- /dev/null
+++ b/modules/home/chrome.nix
@@ -0,0 +1,28 @@
+{ pkgs, lib, ... }: {
+ programs.chromium = {
+ enable = true;
+ package = pkgs.ungoogled-chromium;
+ };
+ programs.chromium.extensions =
+ let
+ createChromiumExtensionFor = browserVersion: { id, sha256, version }:
+ {
+ inherit id;
+ crxPath = builtins.fetchurl {
+ url = "https://clients2.google.com/service/update2/crx?response=redirect&acceptformat=crx2,crx3&prodversion=${browserVersion}&x=id%3D${id}%26installsource%3Dondemand%26uc";
+ name = "${id}.crx";
+ inherit sha256;
+ };
+ inherit version;
+ };
+ createChromiumExtension = createChromiumExtensionFor (lib.versions.major pkgs.ungoogled-chromium.version);
+ in
+ [
+ (createChromiumExtension {
+ # ublock origin
+ id = "cjpalhdlnbpafiamejdnhcphjbkeiagm";
+ sha256 = "sha256:1i0668xhq5iflb4fn0ghwp79iz6mwspgxdqwp6incbvsyzr596kg";
+ version = "1.61.0";
+ })
+ ];
+}