summaryrefslogtreecommitdiff
path: root/modules/home/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/home/default.nix')
-rw-r--r--modules/home/default.nix16
1 files changed, 16 insertions, 0 deletions
diff --git a/modules/home/default.nix b/modules/home/default.nix
new file mode 100644
index 0000000..bce93ba
--- /dev/null
+++ b/modules/home/default.nix
@@ -0,0 +1,16 @@
+{ lib, ... }: {
+ home = {
+ username = "timmy";
+ homeDirectory = "/home/timmy";
+ stateVersion = "24.05";
+ };
+
+ imports = [
+ ./firefox.nix
+ ./git.nix
+ ./initial-home-setup.nix
+ ./theme.nix
+ ];
+
+ theme.mint.enable = lib.mkDefault true;
+}