summaryrefslogtreecommitdiff
path: root/modules/home/theme.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/home/theme.nix')
-rw-r--r--modules/home/theme.nix11
1 files changed, 8 insertions, 3 deletions
diff --git a/modules/home/theme.nix b/modules/home/theme.nix
index 4edaffa..2288610 100644
--- a/modules/home/theme.nix
+++ b/modules/home/theme.nix
@@ -47,15 +47,20 @@ in {
description = "default gtk font";
};
size = lib.mkOption {
- type = lib.types.int;
+ type = with lib.types; nullOr int;
default = null;
description = "default gtk font size";
};
};
};
theme.cursor = {
+ name = lib.mkOption {
+ type = lib.types.str;
+ default = "Adwaita";
+ description = "gtk cursor theme";
+ };
size = lib.mkOption {
- type = lib.types.int;
+ type = with lib.types; nullOr int;
default = null;
description = "gtk cursor size";
};
@@ -78,7 +83,7 @@ in {
size = config.theme.font.gtk.size;
};
cursorTheme = {
- name = "Adwaita";
+ name = config.theme.cursor.name;
size = config.theme.cursor.size;
};
gtk2.configLocation = "${config.xdg.configHome}/gtk-2.0/gtkrc";