summaryrefslogtreecommitdiff
path: root/modules/home/theme.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/home/theme.nix')
-rw-r--r--modules/home/theme.nix8
1 files changed, 8 insertions, 0 deletions
diff --git a/modules/home/theme.nix b/modules/home/theme.nix
index bc8532e..4edaffa 100644
--- a/modules/home/theme.nix
+++ b/modules/home/theme.nix
@@ -53,6 +53,13 @@ in {
};
};
};
+ theme.cursor = {
+ size = lib.mkOption {
+ type = lib.types.int;
+ default = null;
+ description = "gtk cursor size";
+ };
+ };
};
config = {
@@ -72,6 +79,7 @@ in {
};
cursorTheme = {
name = "Adwaita";
+ size = config.theme.cursor.size;
};
gtk2.configLocation = "${config.xdg.configHome}/gtk-2.0/gtkrc";
};