summaryrefslogtreecommitdiff
path: root/modules/hosts/T430/configuration.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/hosts/T430/configuration.nix')
-rw-r--r--modules/hosts/T430/configuration.nix27
1 files changed, 27 insertions, 0 deletions
diff --git a/modules/hosts/T430/configuration.nix b/modules/hosts/T430/configuration.nix
new file mode 100644
index 0000000..a8744ba
--- /dev/null
+++ b/modules/hosts/T430/configuration.nix
@@ -0,0 +1,27 @@
+{ config, lib, pkgs, ... }: {
+ imports = [ ./hardware-configuration.nix ];
+ networking.hostName = "T430";
+
+ # Define a user account. Don't forget to set a password with ‘passwd’.
+ users.users.timmy = {
+ description = "Tim Keller";
+ isNormalUser = true;
+ extraGroups = [ "wheel" "docker" ]; # Enable ‘sudo’ for the user.
+ packages = with pkgs; [
+ ];
+ };
+
+ # TODO this does not function
+ boot.initrd.systemd.extraBin = {
+ sh = "${pkgs.dash}/bin/dash";
+ vim = "${pkgs.neovim}/bin/nvim";
+ };
+
+ # Open ports in the firewall.
+ # networking.firewall.allowedTCPPorts = [ ... ];
+ # networking.firewall.allowedUDPPorts = [ ... ];
+ # Or disable the firewall altogether.
+ # networking.firewall.enable = false;
+
+ system.stateVersion = "24.05";
+}