summaryrefslogtreecommitdiff
path: root/modules/hosts/libreX60/configuration.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/hosts/libreX60/configuration.nix')
-rw-r--r--modules/hosts/libreX60/configuration.nix16
1 files changed, 13 insertions, 3 deletions
diff --git a/modules/hosts/libreX60/configuration.nix b/modules/hosts/libreX60/configuration.nix
index 38500a6..d736763 100644
--- a/modules/hosts/libreX60/configuration.nix
+++ b/modules/hosts/libreX60/configuration.nix
@@ -1,13 +1,23 @@
{ config, lib, pkgs, ... }: {
imports = [ ./hardware-configuration.nix ];
- # Enable extra software pkgs
- software.desktop = {
- office.enable = true;
+ # Use grub
+ bootloader = {
+ loader = "grub";
+ mode = "bios";
+ grub.biosDevice = "/dev/sda";
};
+ # Enable extra software pkgs
+ #software.desktop = {
+ # office.enable = true;
+ #};
+
# Enable network drives
nas.enable = true;
+ # i915 Gpu requires intel driver
+ services.xserver.videoDrivers = [ "intel" ];
+
system.stateVersion = "24.11";
}