summaryrefslogtreecommitdiff
path: root/modules/hosts/libreX60/configuration.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/hosts/libreX60/configuration.nix')
-rw-r--r--modules/hosts/libreX60/configuration.nix13
1 files changed, 13 insertions, 0 deletions
diff --git a/modules/hosts/libreX60/configuration.nix b/modules/hosts/libreX60/configuration.nix
index d736763..e1fa6fd 100644
--- a/modules/hosts/libreX60/configuration.nix
+++ b/modules/hosts/libreX60/configuration.nix
@@ -19,5 +19,18 @@
# i915 Gpu requires intel driver
services.xserver.videoDrivers = [ "intel" ];
+ # Tamzen font in st
+ nixpkgs.overlays = [
+ (final: prev: {
+ st = prev.st.overrideAttrs (old: {
+ buildInputs = old.buildInputs or [] ++ [ pkgs.makeWrapper ];
+ postInstall = old.postInstall or "" + ''
+ wrapProgram $out/bin/st \
+ --add-flags '-fTamzen:pixelsize=14'
+ '';
+ });
+ })
+ ];
+
system.stateVersion = "24.11";
}