summaryrefslogtreecommitdiff
path: root/modules/root/normaluser.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/root/normaluser.nix')
-rw-r--r--modules/root/normaluser.nix8
1 files changed, 8 insertions, 0 deletions
diff --git a/modules/root/normaluser.nix b/modules/root/normaluser.nix
new file mode 100644
index 0000000..5d436e8
--- /dev/null
+++ b/modules/root/normaluser.nix
@@ -0,0 +1,8 @@
+{ userDetails, ... }: {
+ users.users.${userDetails.username} = {
+ description = userDetails.fullname;
+ home = userDetails.home.root;
+ isNormalUser = true;
+ extraGroups = [ "wheel" ];
+ };
+}