summaryrefslogtreecommitdiff
path: root/modules/root/normaluser.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/root/normaluser.nix')
-rw-r--r--modules/root/normaluser.nix6
1 files changed, 5 insertions, 1 deletions
diff --git a/modules/root/normaluser.nix b/modules/root/normaluser.nix
index 97e0a14..fc243ea 100644
--- a/modules/root/normaluser.nix
+++ b/modules/root/normaluser.nix
@@ -1,8 +1,12 @@
-{ userDetails, ... }: {
+{ config, userDetails, ... }: {
+ users.users.root = {
+ hashedPasswordFile = config.sops.secrets.hashed-root-password.path;
+ };
users.users.${userDetails.username} = {
description = userDetails.fullname;
#home = userDetails.home.root;
isNormalUser = true;
+ hashedPasswordFile = config.sops.secrets.hashed-root-password.path;
extraGroups = [ "wheel" "nixbld" ];
};
}