summaryrefslogtreecommitdiff
path: root/modules/root/software.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/root/software.nix')
-rw-r--r--modules/root/software.nix6
1 files changed, 3 insertions, 3 deletions
diff --git a/modules/root/software.nix b/modules/root/software.nix
index c991456..4aa6f64 100644
--- a/modules/root/software.nix
+++ b/modules/root/software.nix
@@ -80,11 +80,11 @@
];
# More desktop
- programs.dconf.enable = lib.mkIf config.software.desktop.enable true; # For home-manager to configure gtk TODO this should be there instead
+ programs.dconf.enable = config.software.desktop.enable; # For home-manager to configure gtk TODO this should be there instead
# More utilities
- programs.zsh.enable = lib.mkIf config.software.utils.enable true;
+ programs.zsh.enable = config.software.utils.enable;
users.defaultUserShell = lib.mkIf config.software.utils.enable pkgs.zsh;
- services.openssh.enable = lib.mkIf config.software.utils.enable true;
+ services.openssh.enable = config.software.utils.enable;
};
}