summaryrefslogtreecommitdiff
path: root/modules/root/software/system.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/root/software/system.nix')
-rw-r--r--modules/root/software/system.nix11
1 files changed, 11 insertions, 0 deletions
diff --git a/modules/root/software/system.nix b/modules/root/software/system.nix
new file mode 100644
index 0000000..18cc8dd
--- /dev/null
+++ b/modules/root/software/system.nix
@@ -0,0 +1,11 @@
+{ pkgs, ... }: {
+ environment.systemPackages = with pkgs; [
+ age # Secrets
+ cryptsetup
+ dash # TODO should be default /bin/sh
+ exfat
+ git # Needed for home-manager
+ python3
+ sops # Secrets
+ ];
+}