summaryrefslogtreecommitdiff
path: root/modules/root/zsh.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/root/zsh.nix')
-rw-r--r--modules/root/zsh.nix10
1 files changed, 10 insertions, 0 deletions
diff --git a/modules/root/zsh.nix b/modules/root/zsh.nix
new file mode 100644
index 0000000..697cb4c
--- /dev/null
+++ b/modules/root/zsh.nix
@@ -0,0 +1,10 @@
+{ lib, config, pkgs, ... }: {
+ options = {
+ zsh.enable = lib.mkEnableOption "use zsh as default shell";
+ };
+
+ config = lib.mkIf config.zsh.enable {
+ programs.zsh.enable = true;
+ users.defaultUserShell = pkgs.zsh;
+ };
+}