summaryrefslogtreecommitdiff
path: root/nixes/startx/startx.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixes/startx/startx.nix')
-rw-r--r--nixes/startx/startx.nix10
1 files changed, 10 insertions, 0 deletions
diff --git a/nixes/startx/startx.nix b/nixes/startx/startx.nix
new file mode 100644
index 0000000..591f426
--- /dev/null
+++ b/nixes/startx/startx.nix
@@ -0,0 +1,10 @@
+#{ pkgs ? import <nixpkgs> { overlays = [ (import /path/to/my-overlay.nix) ]; } }:
+
+final: prev: {
+ xorg.xinit = prev.xorg.xinit.overrideAttrs (old: {
+ # Apply the patch
+ patches = old.patches or [] ++ [
+ ./startx-xdg.patch
+ ];
+ });
+}