summaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
authorTim Keller <tjkeller.xyz>2025-05-05 13:25:38 -0500
committerTim Keller <tjkeller.xyz>2025-05-05 13:25:38 -0500
commit1969493257f4644c3b105b3fc2c82a445a2ae664 (patch)
treefa14e1d54a47b45895a232cec1ae6641af717a05 /flake.nix
parentf59d51611cbe61ff492bd836cea29a7aa33a294c (diff)
downloadnixos-1969493257f4644c3b105b3fc2c82a445a2ae664.tar.xz
nixos-1969493257f4644c3b105b3fc2c82a445a2ae664.zip
use xdg-userdirs functionality
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix10
1 files changed, 5 insertions, 5 deletions
diff --git a/flake.nix b/flake.nix
index 36af18b..ffd028e 100644
--- a/flake.nix
+++ b/flake.nix
@@ -26,11 +26,11 @@ rec {
username = "timmy";
email = "tjkeller.xyz";
fullname = "Tim Keller";
- home = with userDetails; with home; {
- root = "/home/${username}";
- downloads = "${root}/dls";
- documents = "${root}/docs";
- pictures = "${root}/pics";
+ home = "/home/${userDetails.username}";
+ userDirs = with userDetails; {
+ download = "${home}/dls";
+ documents = "${home}/docs";
+ pictures = "${home}/pics";
};
};
homeStateVersion = "24.05"; # Lowest of systems is fine