summaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
authorTim Keller <tjk@tjkeller.xyz>2024-10-02 22:37:06 -0500
committerTim Keller <tjk@tjkeller.xyz>2024-10-02 22:37:06 -0500
commit9d1b3f23a64506988608143f4bca8ab4c5141d3e (patch)
tree0955588a5f4bcb3f802b6398a537a83cdb0091e0 /flake.nix
parent4730b215fdc4095800fedfdf690c12fec994bb6b (diff)
downloadnixos-9d1b3f23a64506988608143f4bca8ab4c5141d3e.tar.xz
nixos-9d1b3f23a64506988608143f4bca8ab4c5141d3e.zip
update moreee
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix13
1 files changed, 12 insertions, 1 deletions
diff --git a/flake.nix b/flake.nix
index e69a67b..fbf3bc1 100644
--- a/flake.nix
+++ b/flake.nix
@@ -19,10 +19,18 @@
let
system = "x86_64-linux";
pkgs = nixpkgs.legacyPackages.${system};
+ userDetails = {
+ username = "timmy";
+ email = "tjkeller.xyz";
+ fullname = "Tim Keller";
+ };
in {
nixosConfigurations.T430 = nixpkgs.lib.nixosSystem {
inherit system;
- specialArgs = { inherit inputs; };
+ specialArgs = {
+ inherit inputs;
+ inherit userDetails;
+ };
modules = [
./modules/hosts/T430/configuration.nix
./modules/root
@@ -31,6 +39,9 @@
homeConfigurations.timmy = home-manager.lib.homeManagerConfiguration {
inherit pkgs;
+ extraSpecialArgs = {
+ inherit userDetails;
+ };
modules = [
./modules/home
inputs.arkenfox.hmModules.arkenfox