summaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix13
1 files changed, 12 insertions, 1 deletions
diff --git a/flake.nix b/flake.nix
index e69a67b..fbf3bc1 100644
--- a/flake.nix
+++ b/flake.nix
@@ -19,10 +19,18 @@
let
system = "x86_64-linux";
pkgs = nixpkgs.legacyPackages.${system};
+ userDetails = {
+ username = "timmy";
+ email = "tjkeller.xyz";
+ fullname = "Tim Keller";
+ };
in {
nixosConfigurations.T430 = nixpkgs.lib.nixosSystem {
inherit system;
- specialArgs = { inherit inputs; };
+ specialArgs = {
+ inherit inputs;
+ inherit userDetails;
+ };
modules = [
./modules/hosts/T430/configuration.nix
./modules/root
@@ -31,6 +39,9 @@
homeConfigurations.timmy = home-manager.lib.homeManagerConfiguration {
inherit pkgs;
+ extraSpecialArgs = {
+ inherit userDetails;
+ };
modules = [
./modules/home
inputs.arkenfox.hmModules.arkenfox